Alpine Achievement Degraded Performance
Incident Report for Illuminate Education
Resolved
A fix has been implemented and this incident has been resolved.
Posted Jan 19, 2021 - 10:36 PST
Update
Some clients may experience issues when attempting to access or edit Plans. Our team is investigating these issues and we will continue to provide updates.
Posted Jan 19, 2021 - 09:48 PST
Investigating
Some clients may experience issues while navigating and using Alpine Achievement. Our team is currently investigating these issues. We will continue to provide updates as they become available.
Posted Jan 19, 2021 - 08:59 PST
This incident affected: Alpine Education.