Latency on eduClimber
Incident Report for Illuminate Education
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 14:45 PDT
Update
We are investigating an issue with some customers not being able to login to eduClimber.
Posted Sep 18, 2023 - 13:12 PDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2023 - 13:11 PDT
This incident affected: eduCLIMBER.