Phone Provider Degrade Performance
Incident Report for Illuminate Education
Resolved
This incident has been resolved.
Posted Aug 16, 2021 - 10:04 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 16, 2021 - 10:03 PDT
Monitoring
Our phone service provider has identified and resolved the issue.
Posted Aug 16, 2021 - 10:01 PDT
Investigating
We are currently experiencing issues with our phone service provider. This may impact your call experience or result in longer wait times. If you experience any issues, please try your call again or send an email to our Support team. We will provide another update in 30 minutes.
Posted Aug 16, 2021 - 09:53 PDT
This incident affected: Support Tools (Phone System).