Itembank Maintenance
Incident Report for Illuminate Education
Resolved
Our maintenance window is complete.
Posted Aug 11, 2020 - 11:49 PDT
Identified
We will have a short maintenance window on New Itembank.
Posted Aug 11, 2020 - 10:45 PDT
This incident affected: Illuminate Application (Archived) (Itembank, Online Testing).