Talkdesk Degraded Performance
Incident Report for Illuminate Education
Resolved
Our phone service provider has identified and resolved the issue.
Posted Jan 19, 2021 - 11:00 PST
Update
Our phone service provider is working to resolve this issue.
Posted Jan 19, 2021 - 10:33 PST
Investigating
We are currently experiencing issues with our phone service provider receiving and routing calls. If you experience any issues, please try your call again or send an email to our support team (https://support.illuminateed.com/hc/en-us/articles/360052008574-Which-Product-am-I-Using-). We will continue to provide additional updates.
Posted Jan 19, 2021 - 09:24 PST
This incident affected: Support Tools (Phone System).