FastBridge - Degraded Performance
Incident Report for Illuminate Education
Resolved
The incident has been resolved.
Posted Dec 06, 2022 - 08:45 PST
Investigating
Some customers may be experiencing latency issues with the FastBridge application. Our engineering team is aware of the issue and is working to resolve it. This page will be updated again when the issue is resolved, thank you for your patience.
Posted Dec 06, 2022 - 08:38 PST
This incident affected: FastBridge.