Illuminate Phone system provider outage
Incident Report for Illuminate Education
Resolved
Talkdesk has restored service.
Posted about 1 year ago. Oct 16, 2017 - 14:59 PDT
Monitoring
The phone system provider (TalkDesk) used by Illuminate Support Team is experiencing issues and inbound voice calls are impacted. E-mail support remains online and we encourage you to use this for any issues or questions. We will monitor the situation and advise when phone service is restored. You may view the TalkDesk status here :http://status.talkdesk.com/
Posted about 1 year ago. Oct 16, 2017 - 14:02 PDT