Illuminate Phone system provider outage
Incident Report for Illuminate Education
Resolved
Our phone provider TalkDesk is reporting that they have largely restored service. We have confirmed that our inbound call routing is working again. You may monitor their status at: http://status.talkdesk.com/
Posted 7 months ago. Oct 09, 2017 - 11:42 PDT
Identified
Our phone system provider is experiencing problems right now and calls to Support aren't getting through. They're working to resolve the issue. In the meantime, please send us an email at help@illuminateed.com and we'll be happy to give you a hand. No Illuminate application or system services are impacted.
Posted 7 months ago. Oct 09, 2017 - 08:43 PDT